
Sloshing Tank

Introduction

This 2D model demonstrates the ability of COMSOL Multiphysics to simulate dynamic free surface flow with the

help of a moving mesh. The study models fluid motion with the incompressible Navier-Stokes equations. The

fluid is initially at rest in a rectangular tank. The motion is driven by the gravity vector swinging back and

forth, pointing up to 4 degrees away from the downward y direction at its extremes.

Figure 6-15: Snapshots of the velocity field at t = 1 s, t = 1.2 s, t = 1.4 s, and t = 1.6 s. The inclination of the gravity vector is indicated

by the leaning of the tank.

Because the surface of the fluid is free to move, this model is a nonstandard computational task. The ALE

(arbitrary Lagrangian-Eulerian) technique is, however, well suited for addressing such problems. Not only is it

easy to set up using the Moving Mesh (ALE) application mode in COMSOL Multiphysics, but it also has the

advantage that it represents the free surface boundary with a domain boundary on the moving mesh. This

allows for the accurate evaluation of surface properties such as curvature, making surface tension analysis

possible. Note, however, that this example model neglects surface tension effects.

Model Definition

DOMAIN EQUATIONS

This model describes the fluid dynamics with the incompressible Navier-Stokes equations:

where ρ is the density, u = (u, v) is the fluid velocity, p is the pressure, I is the unit diagonal matrix, η is the
viscosity, and F is the volume force. In this example model, the material properties are for glycerol:

η = 1.49 Pa·s, and ρ = 1.27·103 kg/m3. The gravity vector enters the force term as
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where g = 9.81 m/s2, , and f = 1 Hz.

With the help of the Moving Mesh (ALE) application mode, you can solve these equations on a freely moving

deformed mesh, which constitutes the fluid domain. The deformation of this mesh relative to the initial shape

of the domain is computed using Winslow smoothing. For more information, please refer to “The Moving Mesh

Application Mode” on page 401 in the COMSOL Multiphysics Modeling Guide. COMSOL Multiphysics takes care of

the transformation of the Navier-Stokes equations to the formulation on the moving mesh.

BOUNDARY CONDITIONS FOR THE FLUIDBOUNDARY CONDITIONS FOR THE FLUIDBOUNDARY CONDITIONS FOR THE FLUIDBOUNDARY CONDITIONS FOR THE FLUID

There are two types of boundaries in the model domain. Three solid walls, that are modeled with slip

conditions, and one free boundary (the top boundary). The slip boundary condition for the Navier-Stokes

equations is

where n = (nx, ny)
T is the boundary normal. To enforce this boundary condition, select the Symmetry

boundary type in the Incompressible Navier-Stokes application mode. Because the normal vector depends on

the degrees of freedom for the moving mesh, a constraint force would act not only on the fluid equations but

also on the moving mesh equations. This effect would not be correct, and one remedy is to use non-ideal weak

constraints. Ideal weak constraints (the other type of weak constraints) do not remove this effect of the

constraint force. For more information about weak constraints, see “Using Weak Constraints” on page 300 in

the COMSOL Multiphysics Modeling Guide. The Incompressible Navier-Stokes application mode does not make

use of weak constraints by default, so you need to activate the non-ideal weak constraints.

The following weak expression, which you add to the model, enforces the slip boundary condition without a

constraint force acting on the moving mesh equations:

(6-9)

for some Lagrange multiplier variable λ. Here λ and u denote test functions. See the step-by-step instructions

later in this model documentation for details.

The fluid is free to move on the top boundary. The stress in the surrounding environment is neglected.

Therefore the stress continuity condition on the free boundary reads

where p0 is the surrounding (constant) pressure and η the viscosity in the fluid. Without loss of generality,

p0 = 0 for this model.

BOUNDARY CONDITIONS FOR THE MESHBOUNDARY CONDITIONS FOR THE MESHBOUNDARY CONDITIONS FOR THE MESHBOUNDARY CONDITIONS FOR THE MESH

In order to follow the motion of the fluid with the moving mesh, it is necessary to (at least) couple the mesh

motion to the fluid motion normal to the surface. It turns out that for this type of free surface motion, it is

important to not couple the mesh motion to the fluid motion in the tangential direction. If you would do so, the

mesh soon becomes so deformed that the solution no longer converges. The boundary condition for the mesh

equations on the free surface is therefore

where n is the boundary normal and (xt, yt)
T the velocity of mesh (see “Mathematical Description of the Mesh

Movement” on page 392 in the COMSOL Multiphysics Modeling Guide). In the Moving Mesh (ALE) application

mode, you specify this boundary condition by selecting the tangent and normal coordinate system in the

deformed mesh and by specifying a mesh velocity in the normal direction, where you enter the right-hand side

expression from above as u*nx+v*ny. The Moving Mesh (ALE) application mode uses non-ideal weak
constraints by default, and for this boundary condition it adds the weak expression

to ensure that there are no constraint forces acting on the fluid equations. Here again, λ denotes some

Lagrange multiplier variable (not the same as before) and λ, x, and y denote test functions. There is no need to
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modify this expression. Choose Physics>Equation System>Boundary Settings and select the free

boundary (boundary 3) to see how to enter this expression in COMSOL Multiphysics. The expression implies

that there is a flux (or force) on the free boundary for the moving mesh coordinate equations  and

, respectively. Furthermore, to be able to follow the fluid motion with the mesh motion, the

moving mesh must not be constrained in the tangential direction on the side walls. In the Moving Mesh (ALE)

application mode, you specify this boundary condition by using the global coordinate system and setting the

mesh displacement to zero in the x direction. At the bottom of the tank the mesh is fixed, which you obtain in a

similar way by setting the mesh displacements to zero in both the x and y directions.

Results

Figure 6-15 on page 247 shows the tank at a few different points in time. The colors represent the velocity

field. Whereas the modeling is set up using a fixed tank and a swinging gravity vector, postprocessing using a

deformation plot gives the tank a corresponding inclination. The inclination angle of the tank is exactly the

same as the angle of the gravity vector from its initial vertical position.

To illustrate the dynamics in the tank, you can plot the wave height versus time at one of the vertical walls, as

in the following plot.

Figure 6-16: Wave height at X = 0.5 m for 0 £ t £ 20 s.

The movie file that accompanies this model shows the waves in the swinging tank, with a color scale indicating

the vorticity.

Model Library Path: COMSOL_Multiphysics/Fluid_Dynamics/sloshing_tank

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator, click the Multiphysics button.

3 Select 2D from the Space dimension list.

4 Select COMSOL Multiphysics>Deformed Mesh>Moving Mesh (ALE)>Transient analysis and click

Add.

5 Click the Application Mode Properties button.

6 Select Winslow from the Smoothing method list. Click OK.

7 Select COMSOL Multiphysics>Fluid Dynamics>Incompressible Navier-Stokes>Transient analysis

and click Add.
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8 Click OK.

GEOMETRY MODELING

1 Shift-click the Rectangle/Square button in the Draw toolbar.

2 Specify the rectangle settings according to the table below

PROPERTY EXPRESSION

Width 1

Height 0.3

Position:
Base

Corner

Position: x -0.5

Position: y 0

3 Click the Zoom Extents button on the Main toolbar.

OPTIONS AND SETTINGS

1 Open the Constants dialog box from the Options menu and enter the following constants. The descriptions

are optional. When done, click OK.

NAME EXPRESSION DESCRIPTION

rho 1270[kg/m^3] Glycerol density

nu 1.49[Pa*s] Glycerol viscosity

phi_max (4*pi/180)[rad] Maximum angle of
inclination

freq 1[Hz] Frequency

g 9.81[m/s^2] Acceleration due to
gravity

2 From the Options menu, choose Expressions>Scalar Expressions.

3 Enter the following scalar variables with names, expressions, and descriptions (the descriptions are

optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

phi phi_max*sin(2*pi*freq*t) Angle of inclination

grav_x g*sin(phi) Gravity vector x
component

grav_y -g*cos(phi) Gravity vector y
component

PHYSICS SETTINGS
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Properties

1 In the Incompressible Navier-Stokes application mode, choose Properties from the Physics menu.

2 In the Application Mode Properties dialog box, select On from the Weak constraints list and

Non-ideal from the Constraint type list; then click OK.

Subdomain Settings

Open the Subdomain Settings dialog box and apply the settings in the table below.

SETTINGS SUBDOMAIN
1

ρ rho

η nu

Fx grav_x*rho

Fy grav_y*rho

Boundary Conditions

1 Open the Boundary Settings dialog box from the Physics menu and enter boundary conditions according

to the table below.

SETTINGS BOUNDARIES
1, 2, 4

BOUNDARY
3

Boundary
type

Wall Open
boundary

Boundary
condition

Slip Normal
stress

f0  0

2 Click OK.

3 Go to the Multiphysics menu and select Moving Mesh (ALE).

4 In the Boundary Settings dialog box, apply the following boundary conditions for the mesh displacements

(only tangential movements on the sides and a fixed mesh at the bottom):

SETTINGS BOUNDARIES
1, 4

BOUNDARY
2

dx 0 0

dy  0

5 On Boundary 3, select Tangent and normal coord. sys. in deformed mesh in the Coordinate system

list. Then click the Mesh velocity button and type u*nx+v*ny in the vn edit field to specify the normal

mesh velocity as u · n.

6 On the Weak Constr. tab of the Boundary Settings dialog box, clear the Use weak constraints check

box on Boundaries 1, 2, and 4. The strong constraints that you specified in the previous step are sufficient

on these boundaries. Leave the Use weak constraints check box selected on Boundary 3.

7 Click OK to close the dialog box.
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MESH GENERATION

Click the Initialize Mesh button on the Main toolbar to initialize the mesh.

COMPUTING THE SOLUTION

1 Open the Solver Parameters window from the Solve menu.

2 Select Time dependent from the Solver list.

3 Enter 0:0.1:6 in the Times edit field.

4 Type 0.001 in the Relative tolerance edit field. This provides a 0.1% relative tolerance, which is one
order of magnitude less than the default value.

5 Click the Time Stepping tab.

6 Select Exclude algebraic in the Error estimation strategy list. This excludes the pressure and the

moving mesh variables from the error estimation. The equations for those variables do not include time

derivatives and become algebraic when solving the equation system using the method of lines.

7 Click OK.

8 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

The default plot shows the x-component of the moving mesh deformation, in the spatial frame.

1 To plot the velocity field of the glycerol instead, go to the Surface tab in the Plot Parameters dialog box

and select Incompressible Navier-Stokes (ns)>Velocity field from the list of expressions.

2 On the General page, clear the Geometry edges check box. Click Apply to see the plot and use the

Solution at time list on the General tab to browse through the output times.

3 On the Deform page, select the Deformed shape plot check box and Set the Scale factor to 1. Enter
Y*sin(phi) in the X component edit field and -X*sin(phi) in the Y component edit field on the
Subdomain Data tab.

4 Still on the Deform page, click the Boundary Data tab. Once again, enter Y*sin(phi) in the X
component edit field and -X*sin(phi) in the Y component edit field.

5 On the Boundary tab, select the Boundary plot check box. Enter 1 in the Expression edit field. Select to
use a Uniform color and pick a black color using the Color button.

6 To get a more liquid-looking plot, you may want to go to the Surface page and set the Colormap to bone.

7 Click Apply to see the plot.

8 To see the waves in action, go to the Animate tab and click Start Animation, then click OK.

To get a more comprehensive overview of the sloshing, you can plot the y-displacement from equilibrium in a
point:

1 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

2 On the Point tab, select Point 4 from the Point selection list.

3 Enter dy_ale in the Expression edit field, then click OK to see the plot.

It is possible to visualize the inclination of the tank by clever use of the deformation plot feature:
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